OSPF – open Shortest Path First, là 1 trong giao thức định tuyến links – state điển hình. Đây là 1 trong những giao thức được sử dụng thoáng rộng trong các mạng doanh nghiệp có kích cỡ lớn. Trong lịch trình CCNA, phía trên cũng là một chủ đề bao gồm được nói nhiều. Vị đó, nắm vững những nguyên tắc hoạt động của OSPF đang giúp các bạn đang theo học lịch trình CCNA hoàn thành tốt kỳ thi lấy hội chứng chỉ thế giới CCNA cũng giống như đáp ứng xuất sắc nhu cầu các bước trong thực tế.

Bạn đang xem: Định tuyến ospf

Một số điểm sáng chính của giao thức OSPF:

OSPF là 1 trong những giao thức links – state điển hình. Từng router khi chạy giao thức đã gửi những trạng thái đường liên kết của nó cho toàn bộ các router vào vùng (area). Sau một thời hạn trao đổi, các router sẽ đồng hóa được bảng cơ sở tài liệu trạng thái đường links (Link State Database – LSDB) với nhau, từng router đều phải có được “bản đồ vật mạng” của tất cả vùng. Từ kia mỗi router vẫn chạy giải mã Dijkstra đo lường và tính toán ra một cây lối đi ngắn tuyệt nhất (Shortest Path Tree) và dựa vào cây này để xây dựng nên bảng định tuyến.OSPF gồm AD = 110.Metric của OSPF còn được gọi là cost, được tính theo bandwidth trên cổng chạy OSPF.OSPF chạy trực tiếp bên trên nền IP, có protocol – id là 89.OSPF là 1 trong giao thức chuẩn chỉnh quốc tế, được quan niệm trong RFC – 2328.

Ta thuộc review buổi giao lưu của OSPF thông qua công việc hoạt động như sau:

Bầu lựa chọn Router – id.Thiết lập quan hệ nam nữ láng giềng (neighbor).Trao thay đổi LSDB.Tính toán xây cất bảng định tuyến.

Router – id:

Đầu tiên, lúc một router chạy OSPF, nó đề xuất chỉ ra một giá bán trị dùng để làm định danh duy nhất cho nó trong xã hội các router chạy OSPF. Quý hiếm này được call là Router – id.

Router – id bên trên router chạy OSPF tất cả định dạng của một add IP. Mặc định, các bước OSPF trên từng router sẽ auto bầu lựa chọn giá trị router – id là add IP tối đa trong những interface đã active, ưu tiên cổng loopback.

Ta cùng làm rõ ý này thông qua ví dụ:

*

Hình 1 – bầu chọn router – id (1).

Khi mang lại router R thâm nhập OSPF (xem hình 1), router R nên bầu chọn ra một ‘nick name’ nhằm định danh R khi R chạy OSPF. Vì ‘nick name’ này còn có định dạng của một địa chỉ cửa hàng IP phải R đang lấy một trong các showroom IP bên trên nó để làm Router – id. Như sẽ nói sinh hoạt trên, chỉ địa chỉ cửa hàng của những interface vẫn active, tức là ở trạng thái up/up (status up, line protocol up) mới được tham gia thai chọn. Ta thấy bên trên hình , chỉ tất cả hai cổng F0/0 cùng F0/1 của R là up/up nên router R sẽ chỉ chăm chú hai showroom trên nhị cổng này là 192.168.1.1 với 192.168.2.1. Để xác định trong hai địa chỉ này, add nào là cao hơn, R triển khai so sánh hai địa chỉ này theo từng octet tự trái quý phái phải, add nào gồm octet thứ nhất lớn hơn được xem là lớn hơn. Ta thấy, cùng với cách so sánh này, showroom 192.168.2.1 được xem như là lớn hơn add 192.168.1.1 phải nó sẽ được sử dụng để gia công router – id. Vậy R sẽ tham gia OSPF với cái giá trị ‘nick name’ – router id là 192.168.2.1.

Cũng ví dụ trên dẫu vậy lần này trên router R tất cả thêm các interface loopback :

*

Hình 2 – thai chọn router – id (2).

Khi ta bật OSPF bên trên router R, R xúc tiến vấn đề bầu chọn router – id. Bởi vì lần này còn có các interface loopback buộc phải R sẽ bỏ qua, không chú ý các địa chỉ của các interface trang bị lý. Hai địa chỉ cửa hàng của nhị interface loopback 1 cùng 2 đã được đối chiếu để lựa chọn ra router – id mang đến router R, và ta thấy rõ ràng 2.2.2.2 > 1.1.1.1 đề nghị router R sẽ lựa chọn 2.2.2.2 làm router – id khi tham gia OSPF. Từ hình 2, ta thấy, 2.2.2.2 không phải là địa chỉ IP cao nhất nhưng vì quy trình ưu tiên cổng loopback nên các địa chỉ trên những cổng loopback sẽ được xem xét trước. Điều này được giải thích là sẽ đem về sự định hình cho tiến trình OSPF vì interface loopback là các loại interface luận lý không lúc nào down trừ khi fan quản trị shutdown interface này.

Thực chất, vấn đề up/down của các interface không ảnh hưởng nhiều lắm cho router – id của các router chạy OSPF. Thật vậy, đưa sử trong ví dụ như trên, router R đã chọn ngừng router – id là 192.168.2.1 là IP của cổng F0/1 (xét trường hợp chưa xuất hiện các interface loopback) với tham gia vào OSPF với router – id 192.168.2.1. Thời điểm này, giả dụ ta có bổ sung cập nhật thêm các interface loopback trên router thì router cũng trở nên không thay đổi lại router – id thành IP của những interface loopback. Rộng nữa, mang lại dù lúc này cổng F0/1 có down, thì router vẫn giữ quý hiếm router – id cơ mà nó đã chọn. Có nghĩa là, router – id đơn thuần chỉ là một chiếc tên. Lúc tên vẫn được chọn thì các bước OSPF sẽ thao tác làm việc với cái tên này và không đổi khác lại nữa. Cổng tất cả IP được trích xuất làm tên của router lúc này có up/down cũng không ảnh hưởng gì cả. Vậy nếu họ muốn đổi lại router – id của quy trình thì sao? Ta phải thực hiện khởi động lại router hoặc gỡ bỏ tiến trình OSPF rồi thông số kỹ thuật lại, lúc đó quy trình bầu lựa chọn router – id đã được tiến hành lại với những interface đã hiện hữu trên router.

Và như vậy, ta thấy việc ưu tiên sử dụng IP bên trên loopback sở hữu nhiều chân thành và ý nghĩa về mặt quản trị hơn là tính định hình của tiến trình. Nó có thể chấp nhận được ngươi quản ngại trị kiểm soát tác dụng hơn những router – id của những router.

Có một cách khác để thiết lập cấu hình lại quý giá router – id mang đến router mà không nhất thiết phải khởi động lại router hoặc cấu hình lại OSPF là sử dụng câu lệnh ‘router-id’ nhằm thiết lập bằng tay giá trị này trên router:

Router(config)#router ospf 1

Router(config-router)#router-id A.B.C.D

Lúc này quý giá của router – id rất có thể không rất cần được là một địa chỉ cửa hàng IP bao gồm sẵn bên trên router. Kề bên đó, nếu các bước OSPF vẫn chạy với router – id đã được thiết lập trước đó, ta buộc phải khởi động lại quy trình OSPF thì mới vận dụng được quý hiếm router – id bắt đầu được chỉ ra rằng trong câu lệnh ‘router – id’. Câu lệnh khởi rượu cồn lại quá trình OSPF:

Router#clear ip ospf process

Reset ALL OSPF processes? : yes Area – id.Hello timer và Dead timer.Hai showroom IP đấu nối đề nghị cùng subnet (một vài trường thích hợp còn yêu mong cùng cả subnet – mask).Thỏa mãn những điều kiện xác thực.Cùng nhảy hoặc thuộc tắt cờ stub.

Ta cùng phân tích từng thông số kỹ thuật đã nêu ngơi nghỉ trên.

Area – id

Nguyên tắc hoạt động của OSPF là từng router đề xuất ghi nhớ bảng cơ sở tài liệu trạng thái đường liên kết của toàn bộ hệ thống mạng chạy OSPF rồi từ đó thực hiện giám sát định tuyến dựa vào bảng cơ sở dữ liệu này. Để sút tải bộ nhớ lưu trữ cũng như mua tính toán cho mỗi router và giảm thiểu lượng thông tin định tuyến đề xuất trao đổi, các router chạy OSPF được chia thành nhiều vùng (area), mỗi router hôm nay chỉ cần được ghi nhớ thông tin cho một vùng cơ mà nó ở trong những số đó (hình 4).

Hình 4 – bản vẽ xây dựng phân vùng trong OSPF.

Cách tổ chức như vậy rõ ràng tiết kiệm tài nguyên mạng cùng tài nguyên trên mỗi router. Kế bên ra, cách tổ chức triển khai này còn cô lập được những bất ổn vào vào một vùng: khi có một links nào kia trên một router up/down, sự kiện này chỉ lan truyền trong nội bộ một vùng và gây ra sự giám sát lại định tuyến của những router trong vùng ấy chứ không tác động đến các router ở trong vùng khác.

Mỗi vùng được chỉ ra sẽ sở hữu được một quý giá định danh mang đến vùng gọi là Area – id. Area – id rất có thể được hiển thị bên dưới dạng một trong những tự nhiên hoặc dưới dạng của một showroom IP. Vi dụ Area 0 hoàn toàn có thể được biểu diễn là Area 0.0.0.0. Một nguyên tắc yêu cầu trong phân vùng OSPF là nếu chia thành nhiều vùng thì sẽ phải tồn tại một vùng với số hiệu 0 – Area 0, Area 0 có cách gọi khác là Backbone Area và đầy đủ vùng khác cần phải có liên kết nối về vùng 0.

Khi thực hiện thông số kỹ thuật phân vùng đến router, ta ko gán cả router vào một vùng mà thực hiện gán link trên router vào trong 1 vùng. Area – id được gán cho liên kết của router chứ chưa hẳn gán cho phiên bản thân router. Ví dụ: bên trên hình 4, ta thấy toàn thể router R2 nằm trong vùng 0 là vì khi thông số kỹ thuật ta đã gán hai link trên R2 vào vùng 0. Hầu như router nhưng có toàn bộ các link đều được gán vào trong 1 vùng thì đang lọt hẳn vào vùng đó cùng được gọi là những Internal router, các Internal router chỉ cần ghi nhớ trạng thái đường liên kết của vùng nhưng mà nó nằm cạnh sát trong. Ta cũng xét tiếp router R4. Router này có một links thuộc vùng 0, lại có một link thuộc vùng 1, vì vậy nó thuộc về cả nhì vùng và buộc phải ghi lưu giữ trạng thái đường liên kết của cả hai vùng. Các router vì thế được hotline là những router ABR – Area Border Router – router biên giới giữa nhì vùng.

Khi nhì router bóng giềng kết nối với nhau sang một link, chúng phải thống duy nhất với nhau về area – id của liên kết này. Cả nhị router đề nghị gán cùng một trong những area – id cho links kết nối giữa bọn chúng với nhau. Nếu điều này bị vi phạm, chúng sẽ không thể tùy chỉnh được tình dục láng giềng thông qua link này và cho nên vì thế không bao giờ có thể thảo luận được tin tức định tuyến qua link. Đó là vấn đề kiện trước tiên trong việc cấu hình thiết lập quan hệ bóng giềng: thống độc nhất vô nhị về area – id trên liên kết kết nối.

Chương trình CCNA ko đề cập mang đến OSPF nhiều vùng nhưng chỉ nói tới OSPF đối kháng vùng, trong các số đó mọi router phần lớn được gán vào một trong những vùng. Phong cách xây dựng đa vùng và các vấn đề cụ thể của nó sẽ tiến hành đề cập chi tiết trong course Route của công tác CCNP.

Hello timer và Dead timer

Hello timer là khoảng thời gian định kỳ gửi gói tin hello ra khỏi một cổng chạy OSPF. Lúc 1 router cảm nhận hello từ nhẵn giềng, nó đang khởi động Dead timer. Ví như sau khoảng thời hạn được chỉ ra trong Dead timer mà router không sở hữu và nhận được gói tin hello từ nhẵn giềng, nó đã coi như láng giềng này không còn và vẫn xóa mọi thông tin mà nó học tập được từ trơn giềng. Ngược lại, cứ các lần nhận được gói tin hello từ bóng giềng, Dead timer lại được reset. Quý hiếm mặc định của hello – timer và dead – timer là 10s cùng 40s. Ta rất có thể hiệu chỉnh các giá trị này trên cổng chạy OSPF bằng cách sử dụng câu lệnh:

R(config-if)#ip ospf dead-interval seconds

Để nhị router tùy chỉnh được quan hệ nam nữ láng giềng cùng với nhau, cặp quý giá này sẽ phải khớp nhau trên nhì router ở nhì đầu của mặt đường link.

Cùng subnet

Hai add IP1 và IP2 đấu nối nhau giữa hai router cần phải cùng subnet thì hai router này mới bao gồm thể cấu hình thiết lập quan hệ láng giềng với nhau (xem hình 3). Một trong những trường thích hợp còn đề xuất hai địa chỉ này buộc phải cùng cả subnet – mask để sở hữu thể tùy chỉnh cấu hình neighbor.

Thỏa mãn authentication

Trong trường vừa lòng để bức tốc tính bảo mật thông tin của chuyển động trao đổi thông tin định tuyến, chúng ta thực hiện thiết lập các pasword trên nhị router nhị đầu mặt đường link. Yêu thương cầu yêu cầu là hai password này nên khớp nhau ở hai đầu để hai router tất cả thể tùy chỉnh neighbor (tất nhiên!). Cấu hình xác thực sai rất có thể dẫn mang lại không tùy chỉnh neighbor được thân hai router từ kia dẫn mang lại không thương lượng được tin tức định tuyến.

Cờ stub

Trong bản vẽ xây dựng đa vùng của OSPF gồm một nhiều loại vùng điện thoại tư vấn là vùng stub. Vùng stub là vùng không mừng đón LSA type – 5. Khi ta đã mang đến một link của một router ở trong vùng stub thì phải đầu tê của links cũng phải gán liên kết này ở trong vùng stub. Lúc đó các gói tin định tuyên hội đàm nhau thân hai đầu sẽ sở hữu cờ stub được nhảy lên. Cụ thể về vùng stub được đề cập rõ ràng trong course Route của chương trình CCNP, công tác CCNA ko cover sự việc này.

Sau khi cả 05 đk nêu trên đã có được thỏa mãn, hai router thiết lập với nhau một mối quan hệ gọi là quan hệ tình dục láng giềng với được cam kết hiệu là 2 – WAY. Khi những router đã tùy chỉnh thiết lập được quan hệ giới tính 2 – WAY cùng với nhau, chúng bước đầu thực hiện hội đàm bảng cơ sở dữ liệu trạng thái đường liên kết (LSDB – links State Database) cho nhau. Bài toán trao thay đổi này được lăn ra toàn mạng và sau cùng mỗi router đều phải sở hữu được tinh thần đường liên kết của hồ hết router trong mạng, từ bỏ đó chúng thực hiện đo lường và thống kê trên cơ sở tài liệu trạng thái đường links này và xây cất bảng định tuyến.

Trao thay đổi LSDB

LSDB – link State Database – Bảng cơ sở tài liệu trạng thái con đường link là 1 trong những bảng bên trên router ghi nhớ đầy đủ trạng thái đường links của đông đảo router vào vùng. Ta có thể coi LSDB là 1 trong những “tấm bạn dạng đồ mạng” mà lại router sẽ căn cứ vào đó để tính toán định tuyến. LSDB phải hoàn toàn giống nhau giữa các router thuộc vùng. Những router sẽ không còn trao thay đổi với nhau cả một bảng LSDB nhưng mà sẽ thương lượng với nhau từng đơn vị chức năng thông tin điện thoại tư vấn là LSA – links State Advertisement. Những đơn vị thông tin đó lại được chứa trong số gói tin rõ ràng gọi là LSU – links State Update mà những router thực sự thương lượng với nhau. Lưu giữ ý: LSA không phải là 1 trong loại gói tin mà chỉ cần một bản tin. LSU bắt đầu thực sự là gói tin cùng nó tiềm ẩn các bạn dạng tin này.

Việc đàm phán thông tin ra mắt rất khác biệt tùy theo từng một số loại network – type gán cho link giữa nhì router. Vào khuôn khổ chương trình CCNA, bọn họ chỉ xét cho hai loại network – type là Point – lớn – Point và Broadcast Multiaccess.

Point – to – point

Loại link point – to lớn – point nổi bật là kết nối serial điểm – điểm chạy giao thức HDLC hoặc PPP nối giữa hai router (hình 5).

Hình 5 – hội đàm LSDB với kết nối point – lớn – point.

Trong trường hòa hợp này, nhị router trơn giềng đã ngay lập tức gửi toàn bộ bảng LSDB cho nhau qua liên kết point – khổng lồ – point và đưa trạng thái tình dục từ 2 – WAY sang 1 mức độ bắt đầu gọi là tình dục dạng FULL. Quan hệ Full qua một kết nối serial point – to lớn – point được ký hiệu là FULL/ – .

Broadcast Multiaccess

Môi trường Broadcast Multiaccess điển hình chính là môi ngôi trường Ethernet LAN (hình 6).

Hình 6 – Broadcast MultiAccess.

Việc đàm phán LSDB ra mắt hoàn toàn không giống trong môi trường này. Với môi trường này, mỗi router đều liên kết trực tiếp cùng với nhau với đều tùy chỉnh quan hệ 2 – WAY cùng với nhau. Mặc dù nhiên, các router sẽ không trao đổi trực tiếp với nhau nhưng sẽ triển khai trao đổi tin tức thông sang 1 router đầu mối điện thoại tư vấn là DR – Designated Router. Trên mỗi liên kết Multi – access, một DR router được thai ra. Một router khác sẽ được bầu có tác dụng Backup DR (BDR) để tham dự phòng cho DR vào trường hòa hợp DR down. Các router còn lại đóng vai trò là DROther. Nguyên tắc đề ra như sau: những router DROther khi trao đổi thông tin định tuyến sẽ không còn gửi trực tiếp cho nhau mà sẽ gửi lên cho DR với BDR. Tiếp nối router DR này đã forward lại tin tức xuống cho các router DROther khác. Khi những router gửi thông tin lên đến DR và BDR, chúng sẽ sử dụng showroom multicast 224.0.0.6 còn khi DR forward lại thông tin xuống các router khác, nó sử dụng địa chỉ cửa hàng 224.0.0.5. Kể lại, các DROther không bàn bạc trực tiếp cùng với nhau.

Hình 7 – vận động trao thay đổi thông tin trải qua DR.

Về quan hệ giữa những cặp router thời gian này, ta thấy như sau:

– Các DROther không bao giờ trao đổi tin tức với nhau đề nghị quan hệ giữa bọn chúng mãi mãi chỉ dừng lại ở mức độ 2 – WAY. Tiến hành show bảng neighbor trên các router DROther đã thấy rằng những router này hiển thị chứng trạng quan hệ cùng nhau là 2-WAY/DROther.

– Các DROther tất cả trao đổi tài liệu với DR cùng BDR bắt buộc trong bảng neighbor của những router DROther, các router DR và BDR sẽ chỉ ra với quan hệ dạng full: FULL/DR cùng FULL/BDR. Ngược lại, các router DR và BDR cũng thấy triệu chứng quan hệ của những router DROther với chúng là FULL/DROther.

Như vậy, router DR đóng một sứ mệnh rất đặc biệt quan trọng trên môi trường Multiaccess: đó là router điều phối thông tin trên môi trường này. Vậy router nào sẽ được chọn có tác dụng DR? Ta bao gồm nguyên tắc bầu chọn DR cùng BDR cho một môi trường multi – access như sau:

– Trên từng cổng đấu nối multi – access của mỗi router đều sở hữu một giá trị hotline là priority. Quý giá priority này phía trong dải từ bỏ 0 cho 255 và được trao đổi giữa những router trong số gói tin hello. Router nào sở hữu giá trị priority cao nhất sẽ được thai chọn có tác dụng DR, priority cao nhì làm cho BDR, sót lại sẽ là DROther. Quý giá priority mang định trên các cổng router là bằng 1. Lưu ý rằng nếu như router với giá trị priority bằng 0 sẽ không tham gia vào quá trình bầu chọn DR và BDR, nó luôn luôn luôn đảm nhiệm vai trò là DROther.

– Trong ngôi trường hợp quý hiếm priority đều nhau (ví dụ để mặc định bằng 1 hết, không cấu hình gì thêm), router nào tất cả Router – id cao nhất sẽ có tác dụng DR, Router – id cao hai sẽ làm cho BDR, sót lại làm DROther. Ta nói Router – id là tie – breaker của Priority.

Có một số để ý cho bài toán bầu chọn DR cùng BDR như sau:

– Nếu ta thông số kỹ thuật một router nhận giá trị priority bằng 0, router này sẽ không tham gia vào quy trình bầu chọn DR và BDR, nó luôn luôn luôn là DROther. Chúng ta phải xem xét điều này vì chưng nếu chúng ta cấu hình cho toàn bộ các router đấu nối vào môi trường multi – access quý giá priority = 0 thì sẽ không có router nào chịu làm DR cho môi trường này! Lỗi này dẫn cho lỗ hổng trong việc trao đổi thông tin định tuyến.

– Luật thai chọn DR là non – preempt: lúc một DR đã được thai chọn xong, trường hợp router mới tham gia vào môi trường xung quanh multi – access tất cả priority tốt router – id cao hơn router DR nó cũng quan trọng chiếm quyền của DR hiện nay tại. Chỉ khi nào DR lúc này down, router khác mới có thời cơ tranh quyền DR.

– Một router hoàn toàn có thể đóng nhiều vai trò không giống nhau trên các cổng multi – acces không giống nhau. Ví dụ: nó rất có thể là DR trên môi trường Multi – access đấu nối vào cổng F0/0 tuy vậy lại là DROther trên môi trường Multi – acces đấu nối vào cổng F0/1.

– Chúng ta không được nhầm lẫn kết nối Ethernet nối 02 router là 1 trong kết nối point – to – point, liên kết này vẫn được coi là Multi – access. Trong trường thích hợp này, một router sẽ làm DR, một có tác dụng BDR, không tồn tại DROther (hình 8).

Hình 8 – Đây là môi trường thiên nhiên Multi – access cho dù chỉ có 02 router.

Sau khi chấm dứt xong thao tác làm việc trao đổi LSDB, từng router trong vùng đều đã có được bảng cơ sở tài liệu trạng thái đường links của những router trong vùng, xuất xắc nói một giải pháp khác, từng router đã chiếm lĩnh “tấm bạn dạng đồ mạng” của cả vùng. Dựa vào LSDB này, các router đang chạy giải mã Dijkstra để tạo một cây đường đi ngắn độc nhất đến đều đích mang đến trong mạng với cội cây chính là router ấy. Trường đoản cú cây này, router thiết kế lên bảng định tuyến đường của mình. Cụ thể về lời giải Dijkstra xin không kể ở đây. Các bạn quan tâm hoàn toàn có thể tìm hiểu thông qua các giáo trình về Toán rời rộc rạc hoặc kim chỉ nan đồ thị của các trường Đại học. Nội dung bài viết này sẽ giới thiệu cách OSPF thống kê giám sát metric cho các đường đi với cách người quản trị nhìn vào sơ vật mạng để xác định đường đi mà OSPF đã lựa chọn mà chưa phải “chạy” thuật toán Dijkstra vào đầu ^^:

Tính toán metric với OSPF

Metric vào OSPF được call là cost, được xác định phụ thuộc bandwidth danh định của mặt đường truyền theo công thức như sau:

Metric = cost = 10^8/Bandwidth (đơn vị bps).

Ta rành mạch giữa bandwidth danh định bên trên cổng và vận tốc thật của cổng ấy. Hai giá bán trị này sẽ không nhất thiết buộc phải trùng nhau và quý giá danh định mới chính là giá trị được thâm nhập vào đo lường và thống kê định tuyến. Quý giá danh định được cấu hình thiết lập trên cổng bởi câu lệnh:

R(config-if)#bandwidth BW(đơn vị là kbps)

Ta cần chỉnh quý hiếm danh định này trùng với tốc độ thật của cổng để tránh việc giám sát và đo lường sai lầm trong định tuyến. Ví dụ: một con đường leased – line kết nối vào cổng serial chỉ có vận tốc thật là 512kbps tuy nhiên giá trị bandwidth danh định trên cổng serial luôn luôn là 1.544Mbps làm việc mặc định. Điều kia dẫn cho OSPF coi một cổng 512 kbps như 1 cổng 1.544 Mbps! Ta phải thiết yếu lại đường truyền danh định bên trên cổng vào trường phù hợp này để phản ánh đúng vận tốc thật:

R(config-if)#bandwidth 512

Dựa vào cách làm metric đang nêu sinh sống trên, ta có giá trị cost mặc định của một vài loại cổng:

Ethernet (BW = 10Mbps) -> cost = 10.

Fast Ethernet (BW = 100Mbps) -> cost = 1.

Serial (BW = 1.544Mbps) -> cost = 64 (chặt dồn phần thập phân trong phép chia).

Ta cùng lưu ý một lấy một ví dụ để điều tra khảo sát cách đo lường và tính toán path – cost cho một đường đi:

Hình 9 – Sơ thiết bị ví dụ tính path – cost.

Yêu cầu đề ra với sơ vật dụng hình 9 là tính path – cost (metric) cho lối đi từ R1 đến mạng 192.168.3.0/24 của R3.

Ta thấy một biện pháp dễ dàng: từ bỏ R1 đi mang đến mạng 192.168.3.0/24 của R3 đã đi qua những đường liên kết Fast Ethernet gồm cost = 1, serial gồm cost là 64 và liên kết Fast Ethernet gồm cost bằng 1. Vậy tổng cost tích trữ sẽ là 1 trong những + 64 + một là 66. Metric tự R1 cho mạng 192.168.3.0/24 là 66.

Tuy nhiên việc giám sát và đo lường sẽ trở nên phức hợp hơn giả dụ hai cổng router ở hai đầu links không nhất quán về giá trị cost. Ví dụ, ta vào cổng F0/0 của R2 đổi lại cực hiếm cost thành 64 bằng phương pháp đánh lệnh tiếp sau đây trên cổng F0/0 của R2:

R2(config)#interface f0/0

R2(config-if)#ip ospf cost 64

Vậy câu hỏi đặt ra là với links Fast Ethernet nối thân R1 cùng R2 ta lựa chọn cost của link này là 1 trong những hay 64? nếu tìm là 1, tổng cost toàn tuyến vẫn giữ quý giá như cũ là 66, nhưng nếu tìm là 64, tổng cost toàn tuyến đường sẽ là 64 + 64 + một là 129, hai giá trị rất khác nhau!

Hình 10 – Tổng path – cost là 66 xuất xắc 129?

Để vấn đáp được thắc mắc này, ta đề nghị nắm hiệ tượng sau đâu trong câu hỏi tính tổng cost cùng với OSPF:

Để tính tổng cost từ một router cho một mạng đích theo một con đường (path) làm sao đó, ta tiến hành lần ngược từ đích lần về và cộng dồn cost theo quy tắc đi vào thì cộng, đi ra thì không cộng.

Áp dụng quy tắc này cho ví dụ nghỉ ngơi hình 10: để tính tổng cost từ R1 đến mạng 192.168.3.0/24, ta đi ngược trường đoản cú mạng 192.168.3.0/24 đi về. Khi đi về ta đi vào cổng F0/0 của R3, cùng giá trị cổng này (tổng cost bây giờ là 1); đi ra khỏi cổng S2/0 của R3, bỏ lỡ không cộng (tổng cost vẫn là 1); đi tiếp vào cổng S2/0 của R2, cộng giá trị cổng này (lúc này tổng cost là 1 trong những + 64 = 65); đi ra khỏi cổng F0/0 của R2, bỏ qua mất không cùng (tổng cost vẫn chính là 65); đi tiếp vào cổng F0/0 của R1, cộng giá trị cổng này (tổng cost là 65 + 1 = 66), kết thúc hành trình. Vậy tổng cost vẫn luôn là 66, việc biến đổi giá trị cost bên trên cổng F0/0 không tác động gì mang đến path – cost từ R1 đi mang lại 192.168.3.0/24.

Hình 11 – những cổng gia nhập vào tiến trình giám sát và đo lường path – cost với OSPF.

Như vậy với OSPF, để đánh giá đúng được cost của lối đi và rất có thể hiệu chỉnh cost bên trên cổng để bẻ đường đi của gói tin theo ý muốn, ta buộc phải phải cảnh giác trong việc xác định xem cổng nào trê tuyến phố đi sẽ tham gia vào đo lường để hiệu chỉnh đúng cổng vày hiệu chỉnh không đúng cổng sẽ không mang lại ngẫu nhiên thay thay đổi gì.

Trên đây, họ đã cùng nhau review một số nét chính trong hoạt động vui chơi của OSPF solo vùng trải qua các bước hoạt động vui chơi của tiến trình OSPF: chọn Router – id, thiết lập quan hệ trơn giềng, hiệp thương LSDB và giám sát và đo lường xây dựng bảng định tuyến.

Tiếp theo chúng ta cùng review lại phương thức cấu hình OSPF thông qua ví dụ được trình diễn dưới đây.

Cấu hình

Hình 12 – Sơ vật ví dụ cấu hình.

Trên hình 12 là 4 router thay mặt cho bốn đưa ra nhánh không giống nhau của một doanh nghiệp: R1 cho trụ sở 1, R2 cho chi nhánh 2, R3 cho chi nhánh 3 với R4 cho chi nhánh 4. Những interface loopback trên những router thay mặt cho những mạng nội cỗ của mỗi bỏ ra nhánh, sử dụng những subnet bên trên R1, R2, R3 với R4 thứu tự là 192.168.1.0/24, 192.168.2.0/24, 192.168.3.0/24 và 192.168.4.0/24. Bốn router này đấu nối cùng nhau thông qua 1 kết nối multi – access (đại diện bởi một Ethernet Switch), sử dụng subnet là 192.168.123.0/24 (trên thực tế, đây có thể là một môi trường Metro net đấu nối giữa các chi nhánh). Router R3 và R4 còn triển khai đấu nối riêng với nhau bởi một con đường leased – line trải qua các cổng serial, áp dụng subnet 192.168.34.0/24.

Yêu cầu đề ra là chạy định đường OSPF đảm bảo an toàn mọi add trên sơ thiết bị này thấy nhau.

Để tiến hành chạy OSPF trên các router, bọn họ sử dụng câu lệnh sau:

R(config)#router ospf process-id

R(config-router)#network địa chỉ IP wildcard-mask area area-id

Trong đó:

Process – id: số hiệu của tiến trình OSPF chạy xe trên router, chỉ có chân thành và ý nghĩa local trên router

Để cho một cổng thâm nhập OSPF, ta thực hiện “network” showroom mạng của cổng đó. Với OSPF ta phải sử dụng thêm wildcard – mask để lấy chính xác subnet tham gia định tuyến. Ta cũng bắt buộc chỉ ra links thuộc area nào bằng tham số “area”.

Cấu hình trên những router:

Trên router R1:

R1(config)#router ospf 1

R1(config-router)#network 192.168.123.0 0.0.0.255 area 0

R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Trên router R2:

R2(config)#router ospf 1

R2(config-router)#network 192.168.123.0 0.0.0.255 area 0

R2(config-router)#network 192.168.2.0 0.0.0.255 area 0

Trên router R3:

R3(config)#router ospf 1

R3(config-router)#network 192.168.123.0 0.0.0.255 area 0

R3(config-router)#network 192.168.34.0 0.0.0.255 area 0

R3(config-router)#network 192.168.3.0 0.0.0.255 area 0

Trên router R4:

R4(config)#router ospf 1

R4(config-router)#network 192.168.123.0 0.0.0.255 area 0

R4(config-router)#network 192.168.34.0 0.0.0.255 area 0

R4(config-router)#network 192.168.4.0 0.0.0.255 area 0

Ta thấy khi mong cho cổng F0/0 bên trên router gia nhập OSPF , ta “network” mạng 192.168.123.0/24 bên trên cổng này. Cực hiếm wildcard – mask được xem cho /24 sẽ là 0.0.0.255 (để tính được giá trị wildcard mask, ta lấy giá trị 255.255.255.255 trừ đi cực hiếm subnet – mask 255.255.255.0 từng octet một vẫn được kết quả cần tìm. Phương pháp tính này chỉ hợp lý cho một dải IP liên tiếp, không phải đúng cho đều trường hợp. Về wildcard – mask sẽ có được một nội dung bài viết khác đề cập cụ thể cho vấn đề này). Tựa như với những cổng khác của các router.

Kiểm tra bằng phương pháp hiển thị bảng định tuyến của các router:

Trên R1:

R1#sh ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 <110/2> via 192.168.123.4, 00:00:29, FastEthernet0/0

O 192.168.34.0/24 <110/65> via 192.168.123.4, 00:00:29, FastEthernet0/0

<110/65> via 192.168.123.3, 00:00:29, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 <110/2> via 192.168.123.2, 00:00:29, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 <110/2> via 192.168.123.3, 00:00:29, FastEthernet0/0

Trên R2:

R2#show ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 <110/2> via 192.168.123.4, 00:01:20, FastEthernet0/0

O 192.168.34.0/24 <110/65> via 192.168.123.4, 00:01:20, FastEthernet0/0

<110/65> via 192.168.123.3, 00:01:20, FastEthernet0/0

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 <110/2> via 192.168.123.1, 00:01:20, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 <110/2> via 192.168.123.3, 00:01:20, FastEthernet0/0

Trên R3:

R3#show ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 <110/2> via 192.168.123.4, 00:02:07, FastEthernet0/0

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 <110/2> via 192.168.123.1, 00:02:07, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 <110/2> via 192.168.123.2, 00:02:07, FastEthernet0/0

Trên R4:

R4#show ip route ospf

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 <110/2> via 192.168.123.1, 00:21:57, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 <110/2> via 192.168.123.2, 00:21:57, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 <110/2> via 192.168.123.3, 00:21:57, FastEthernet0/0

Ta thấy rằng các subnet sống xa đã có được học thông qua OSPF (các route OSPF được cam kết hiệu bởi ký từ “O”).

Một điểm độc đáo chúng ta để ý là các mạng loopback khi hiển thị vào bảng định tuyến của những router phần nhiều được OSPF đưa thành /32. Đây là 1 trong nét trong buổi giao lưu của giao thức OSPF, một một số loại giao thức cung cấp cho từng router một chiếc nhìn tổng quan toàn mạng chứ không phải chỉ phụ thuộc vào “tin đồn được lan truyền” như cùng với Distance – vector. Với cái nhìn như vậy, từng router xác minh được mạng loopback nằm ở một cổng không đấu nối đi đâu cả cùng chỉ gồm một add của cả một mạng được sử dụng. /32 được áp dụng để đề đạt điều này. Để tương khắc phục hiện tượng này và làm cho các subnet loopback được hiển thị đúng giá trị prefix –length, ta chuyển đổi kiểu network – type bên trên interface loopback thành đẳng cấp “point – lớn – point” bởi câu lệnh:

R(config)#interface loopback 0

R(config-if)#ip ospf network point-to-point

Chi tiết về những “network – type “ được sử dụng trong OSPF sẽ được đề cập trong các bài viết khác trong kích cỡ của công tác CCNP.

Ta cùng điều tra bảng neighbor trên các router:

Trên R4:

R4#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.3.1 0 FULL/ – 00:00:34 192.168.34.3 Serial2/0

192.168.1.1 1 FULL/DROTHER 00:00:32 192.168.123.1 FastEthernet0/0

192.168.2.1 1 FULL/DROTHER 00:00:34 192.168.123.2 FastEthernet0/0

192.168.3.1 1 FULL/BDR 00:00:37 192.168.123.3 FastEthernet0/0

Ta thấy, R4 đã tùy chỉnh quan hệ bóng giềng với các router còn lại. Qua cổng F0/0, nó thấy 03 router láng giềng bao gồm router – id là 192.168.1.1, 192.168.2.1, 192.168.3.1. Chứng trạng quan hệ cũng chứng minh quan hệ là dạng FULL cùng vai trò của những router bóng giềng trong môi trường multi – access. Từ hiệu quả show làm việc trên, ta thấy rất ví dụ router R1 (192.168.1.1), R2 (192.168.2.1) là những DROther router, R3 (192.168.3.1) là BDR router cùng dĩ nhiên, ta hoàn toàn có thể suy ra được R4 đó là DR router. DR tùy chỉnh cấu hình quan hệ dạng FULL với tất cả các router trong môi trường thiên nhiên multi – access.

Ta cũng thấy rằng R4 cũng thiết lập quan hệ trơn giềng dạng FULL cùng với R3 qua cổng serial 2/0. Vì đó là cổng point – to lớn – point nên các router không bầu chọn DR với BDR với quan hệ giữa hai router được cam kết hiệu là FULL/-.

Trên R1:

R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.2.1 1 2WAY/DROTHER 00:00:30 192.168.123.2 FastEthernet0/0

192.168.3.1 1 FULL/BDR 00:00:32 192.168.123.3 FastEthernet0/0

192.168.4.1 1 FULL/DR 00:00:31 192.168.123.4 FastEthernet0/0

Trên kết quả show của R1, ta cũng thấy các láng giềng R2 (192.168.2.1), R3(192.168.3.1) với R4 (192.168.4.1) với vai trò của từng bé router trong môi trường thiên nhiên multi – access. Ta chú ý rằng R1 chỉ bảo trì quan hệ ở tầm mức 2WAY với R2, cũng là 1 trong DROther kiểu như nó. Hai DROther không khi nào trao đổi trực tiếp tin tức định tuyến đường với nhau bắt buộc không khi nào thiết lập được quan hệ giới tính dạng FULL.

Xem thêm: Bài 2 Gdqp An 12, Một Số Hiểu Biết Về Nền Quốc Phòng Toàn Dân An Ninh Nhân Dân

Thực hiện kiểm tra giống như với những router R2 và R3.

Trên đây, chúng ta đã cùng đánh giá lại chuyển động cơ bạn dạng của giao thức OSPF trong lịch trình CCNA. Đây là 1 trong những giao thức mạnh, hội tụ nhanh, chạy được trên các mạng gồm quy mô bự và đặc biệt là một giao thức chuẩn hóa rất có thể chạy được trên nhiều dòng sản phẩm của đa số hãng khác biệt do này được sử dụng những trong thực tế. Nắm vững đặc điểm chuyển động và cấu hình của OSPF vẫn giúp bọn họ hoàn thành xuất sắc kỳ thi lấy chứng chỉ nước ngoài CCNA và thỏa mãn nhu cầu tốt yêu cấu công việc